系統需求

本安裝以 Drupal 6.x 為基礎,可到 http://drupal.org/requirements 參考完整資訊。在此簡述如下:

網站伺服器

  • Apache 2.2.14 以上
  • 啟用 mod_rewrite(網站目錄的AllowOverride 設為 ALL,以供改寫網址)

資料庫伺服器

  • MySQL 5.0.41 以上

程式語言

  • PHP 5.2.12 以上
  • 安裝時要加上以下 extension:php-gd, php-mysql, php-pdo, php-xmlrpc, php-mbstring, php-xml
  • php.ini 設定請修改:
    • PHP register globals: Disabled
    • PHP memory limit: 128M
    • upload_max_filesize: 10M
    • session.save_handler: user
    • error_reporting:E_ALL & ~E_NOTICE
    • session.cache_limiter: nocache